Skip to Content
Texas State University

Zoom for TXST Mac Computers

Get Started

  • Your Mac must have Jamf installed on the computer to install this software.
  • Mac OS X (10.12 or higher) is required.

NOTE: This version of Zoom for Mac is to be installed on Texas State-owned computers only. Also see Zoom for personal computers.

If you have questions about these prerequisites, please contact ITAC your department's technical support person (TSP) before proceeding.


Installation Instructions

  1. Open Jamf.
  2. Locate and install the software.

NOTE: If you use Outlook often, also consider installing the Zoom Outlook Plugin. Then you can setup Zoom meetings right from your Outlook calendar!